26.10.2015

Функции Excel IF и TODAY для вычисления сроков

Вычисление разницы между 2 датами и метод вычисления разницы между первой датой, и сегодняшней даты если второй даты в строке нет. В своей работе мне часто приходится вычислять сроки различных активностей, для простоты я выберу в качестве примера сроки написания отчетов.

Предположим мы имеем отчет из системы по текущим и завершенным каким либо отчетам различных пользователей, в нем содержатся такие столбы как: логин; ID отчета; дата создания; дата завершения. Необходимо произвести вычисления сроков завершенных и незавершенных ответов.

Перед нами стоят задачи:

  1. Узнать срок от даты создания до даты завершения
  2. Узнать сколько дней пишется отчет если он не завершен.

1. Для решения первой задачи мы можем использовать обычное вычитание: Дата завершения отчета — Дата создания отчета (в примере D2-C2).

Вычисления разницы дат excel

2. Основная проблема заключается во 2 задаче, ведь в данном случае мы не имеем даты завершения отчета, а следовательно формула будет выдавать ошибку:

Ошибка вычисления разницы дат excel

Поэтому необходимо применить ЕСЛИ (IF) для определения пустой ячейки, а после использовать СЕГОДНЯ (TODAY) для получения сегодняшней даты:

=ЕСЛИ(D5=0;СЕГОДНЯ()-C5;D5-C5) — ЕСЛИ определяет равна ли ячейка D5 нулю, если равна то применяет формулу СЕГОДНЯ()-C5, если ячейка содержит значение больше нуля, то применяет D5-C5.

Вычисления разницы дат и сегодняшнего дня excel

Таким образом можно высчитать сроки по различным задолженностям и активностями у которых нет даты завершения.